Degraded performance

Incident Report for Solana

Resolved

The Solana Network is stable.
Posted Mar 10, 2022 - 16:43 UTC

Investigating

The Solana Network is currently experiencing degraded performance, we are currently investigating.
Posted Mar 10, 2022 - 15:24 UTC
This incident affected: Mainnet Beta - Cluster.